1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30]
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] icon

1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30]



Название1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30]
Дата конвертации04.10.2012
Размер47.89 Kb.
ТипДокументы
источник

1 ВАРИАНТ

1 Черепашке был дан для исполнения следующий алгоритм:
Повтори 4 [Направо 30 Вперед 20 Направо 30]. Какая фигура появится на экране?

1) правильный четырехугольник 2)правильный треугольник

3) правильный шестиугольник 4) незамкнутая ломаная линия

2 Черепашке был дан для исполнения следующий алгоритм:
Повтори 11 [Направо 18 Вперед 36 Направо 18]. Какая фигура появится на экране?

  1. правильный треугольник 2) правильный четырехугольник

3) правильный пятиугольник 4)правильный десятиугольник

3 Робот находится в лабиринте. Длина стен неизвестна. Составьте программу закрашивания внутренней части лабиринта.





4 Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки символов, и если она нечетна, то удаляется средний символ, если четна, то к исходной цепочке символов слева приписывается цифра 7. В полученной строке каждая цифра заменяется на предыдущую (1 заменяется на 0, 2 – на 1 и т.д), а 0 заменяется на 9. Получившаяся таким образом цепочка является результатом работы алгоритма.

Например, если исходной цепочкой была цепочка 95347, то результатом работы алгоритма будет цепочка 8436, а если исходной цепочкой была 4268, то результатом работы алгоритма будет цепочка 63157.

Дана цепочка символов 71594. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (то есть применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)?





2 ВАРИАНТ

1 Робот находится в лабиринте. Длина стен неизвестна. Составьте программу закрашивания внутренней части лабиринта













2 Черепашке был дан для исполнения следующий алгоритм:
^ Повтори 3 [Направо 45 Вперед 20 Направо 45]. Какая фигура появится на экране?

1) правильный четырехугольник 2)правильный треугольник

3) правильный шестиугольник 4) незамкнутая ломаная линия

3 Черепашке был дан для исполнения следующий алгоритм:
^ Повтори 9 [Направо 45 Вперед 30]. Какая фигура появится на экране?

  1. правильный шестиугольник 2) правильный четырехугольник

3) правильный восьмиугольник 4)правильный девятиугольник

4 Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки символов, и если она нечетна, то дублируется средний символ, (т.е. к этому символу дописывается такой же), если четна, то из строки удаляется предпоследний символ. В полученной строке каждая цифра заменяется на предыдущую (1 заменяется на 0, 2 – на 1 и т.д), а 0 заменяется на 9. Получившаяся таким образом цепочка является результатом работы алгоритма.

Например, если исходной цепочкой была цепочка 432, то результатом работы алгоритма будет цепочка 3221, а если исходной цепочкой была 6513, то результатом работы алгоритма будет цепочка 542.

Дана цепочка символов 368. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (то есть применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)?


5 Даны 6 строк, которые нумеруются от 0 до 5. Нулевая строка состоит из одного символа – 0 (ноль). Каждая из последующих строк создается такими действиями: в очередную строку дважды подряд приписывается предыдущая строка и в конце приписывается номер строки.

Вот первые 4 строки созданные по этому правилу:

  1. 0

  2. 001

  3. 0010012

  4. 001001200100123

Запишите символ, стоящих в последней строке на 61 месте (считая слева на право).


6 Исполнитель Кузнечик живет на числовой оси. Начальное положение – точка 7. Кузнечик выполнил следующий алгоритм 2 раза:

вперед 5; назад 2;

ЕСЛИ четное

ТО назад 2; закрась

ИНАЧЕ вперед 5; вперед 5

КОНЕЦ

Определите, сколько точек на числовой прямой будет закрашено в результате выполнения этого алгоритма.

7

Исполнитель Чертежник живет на координатной плоскости. Ему дан для исполнения алгоритм:

Повтори 4 раза

Сместиться на(-7,-5)

Сместиться на(8,8)

Сместиться на(-4,-9)

Сместиться на(2,5)

конец

Какую команду надо выполнить Чертежнику, чтобы вернуться в точку, из которой он начал движение

1)Сместиться на(-4,4) 2)Сместиться на(4,-4)

3)Сместиться на(4,4) 4)Сместиться на(-4,-4)





5 Даны 6 строк, которые нумеруются от 0 до 5. Нулевая строка состоит из одного символа – 0 (ноль). Каждая из последующих строк создается такими действиями: в очередную строку дважды подряд приписывается предыдущая строка и в конце приписывается номер строки.

Вот первые 4 строки созданные по этому правилу:

  1. 0

  2. 001

  3. 0010012

  4. 001001200100123

Запишите символ, стоящих в последней строке на 63 месте (считая слева на право).

6 Исполнитель Кузнечик живет на числовой оси. Начальное положение – точка 6.

Кузнечик выполнил следующий алгоритм 3 раза:

вперед 5; назад 2;

ЕСЛИ четное

ТО назад 2; закрась

ИНАЧЕ вперед 5; назад 2

КОНЕЦ

Определите, сколько точек на числовой прямой будет закрашено в результате выполнения этого алгоритма.

7

Исполнитель Чертежник живет на координатной плоскости. Ему дан для исполнения алгоритм:

Повтори 4 раза

Сместиться на(-6,5)

Сместиться на(8,-2)

Сместиться на(4,-9)

Сместиться на(-7,8)

конец

Какую команду надо выполнить Чертежнику, чтобы вернуться в точку, из которой он начал движение

  1. Сместиться на(-4,8)

  2. Сместиться на(4,-8)

  3. Сместиться на(4,8)

  4. Сместиться на(-4,-8)




Похожие:

1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconХищные Баштанник Н. Е. 2008-2009 учебный год
Собачьи. Верхний ряд, слева направо: волк, шакал, койот. Нижний ряд, слева направо: песец, енотовидная собака, лисица Медвежьи. Слева...
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconУбывает слева направо (от натрия к алюминию) из-за уменьшения размера иона металла. Слева направо по периоду по этой же причине ослабевают металлические свойства
Убывает слева направо (от натрия к алюминию) из-за уменьшения размера иона металла. Слева направо по периоду по этой же причине ослабевают...
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconКомплекс упражнений фм для младших школьников на уроках с элементами письма
Упражнение для улучшения мозгового кровообращения. И. п. – сидя, руки на поясе. 1- поворот головы направо; 2- и п.; 3- поворот головы...
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconСказительница. Жил да был в одной деревеньке Парень бравый звали его Сенькой. Жил да был, он не тужил, с девкой Настею дружил, На свиданья к ней ходил. Сенька
Военком. Стройся! Равняйсь! Смирно! Направо! Шагом марш! Запевай! Уходят в другой конец зала
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconЧетвертной поворот направо Quarter Turn to R

1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconПрограмма для уничтожения компьютерных ви­русов. Алгоритм это: а правила выполнения определенных действий
Дан целочисленный массив A(n). Определить количество элементов, значение которых больше Составить блок – схему или алгоритм
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconАквариум для рыбок
Закрепить пространственные отношения: вверх, вниз, влево, вправо, снизу вверх, сверху вниз, слева направо, справа налево
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconЗадание 2 Анализ стихотворения
Вихрем мчится, сплошной поток, прямо, кругами, налево и направо носится, вдоль, вокруг, спешат
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] iconСемья варич
Для памяти своей семье: жене Тане и деткам дочке Тае и сыночку Венечке. Привет г. Каунас. Фото 17 41г. Слева направо: Г. П. Варич,...
1 вариант №1 Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 30 Вперед 20 Направо 30] icon«Олимпийская викторина»
Назовите цвета пяти переплетенных колец современного символа олимпийского движения (слева направо верхний ряд, затем нижний)
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©lib2.podelise.ru 2000-2013
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы